<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://frontstretch.com/xmlrpc.php" />
<title>5 Cup Series Drivers Who Need to Win in 2017</title>
<meta property="og:title" content="5 Cup Series Drivers Who Need to Win in 2017 - Frontstretch"/>
<meta property="og:type" content="article"/>
<meta property="og:description" content="When NASCAR announced changes to the race format late last month, it made consistency relevant again"/>
<meta property="og:url" content="https://frontstretch.com/2017/02/07/5-cup-series-drivers-who-need-to-win-in-2017/"/>
<meta property="og:site_name" content="Frontstretch"/>
<meta property="og:image" content="https://frontstretch.com/wp-content/uploads/2015/09/2015-Chicago-CUP-Clint-Bowyer-Danica-Patrick-CIA-660x439.jpg" />

<!-- This site is optimized with the Yoast SEO plugin v4.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="When NASCAR announced changes to the race format late last month, it made consistency relevant again. Winning is still going to have its virtues, including"/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://frontstretch.com/2017/02/07/5-cup-series-drivers-who-need-to-win-in-2017/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="5 Cup Series Drivers Who Need to Win in 2017" />
<meta property="og:description" content="When NASCAR announced changes to the race format late last month, it made consistency relevant again. Winning is still going to have its virtues, including" />
<meta property="og:url" content="https://frontstretch.com/2017/02/07/5-cup-series-drivers-who-need-to-win-in-2017/" />
<meta property="og:site_name" content="Frontstretch" />
<meta property="article:publisher" content="https://www.facebook.com/Frontstretch" />
<meta property="article:author" content="https://www.facebook.com/Dustin-Albino-1649260695340254/?ref=aymt_homepage_panel" />
<meta property="article:tag" content="Clint Bowyer" />
<meta property="article:tag" content="Danica Patrick" />
<meta property="article:tag" content="Erik Jones" />
<meta property="article:tag" content="Kasey Kahne" />
<meta property="article:tag" content="Ricky Stenhouse Jr." />
<meta property="article:section" content="Cup Series News" />
<meta property="article:published_time" content="2017-02-07T22:00:13-05:00" />
<meta property="article:modified_time" content="2017-02-07T22:43:40-05:00" />
<meta property="og:updated_time" content="2017-02-07T22:43:40-05:00" />
<meta property="og:image" content="https://frontstretch.com/wp-content/uploads/2015/09/2015-Chicago-CUP-Clint-Bowyer-Danica-Patrick-CIA.jpg" />
<meta property="og:image:width" content="720" />
<meta property="og:image:height" content="480" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="When NASCAR announced changes to the race format late last month, it made consistency relevant again. Winning is still going to have its virtues, including" />
<meta name="twitter:title" content="5 Cup Series Drivers Who Need to Win in 2017" />
<meta name="twitter:site" content="@Frontstretch" />
<meta name="twitter:image" content="https://frontstretch.com/wp-content/uploads/2015/09/2015-Chicago-CUP-Clint-Bowyer-Danica-Patrick-CIA.jpg" />
<meta name="twitter:creator" content="@DustinAlbino" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Feed" href="https://frontstretch.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Comments Feed" href="https://frontstretch.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Frontstretch &raquo; iCal Feed" href="https://frontstretch.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; 5 Cup Series Drivers Who Need to Win in 2017 Comments Feed" href="https://frontstretch.com/2017/02/07/5-cup-series-drivers-who-need-to-win-in-2017/feed/" />
		<script type="text/javascript">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</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='tie-insta-style-css'  href='https://frontstretch.com/wp-content/plugins/instanow/assets/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='taqyeem-style-css'  href='https://frontstretch.com/wp-content/plugins/taqyeem/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://frontstretch.com/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='taqyeem-buttons-style-css'  href='https://frontstretch.com/wp-content/plugins/taqyeem-buttons/assets/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-style-css'  href='https://frontstretch.com/wp-content/themes/sahifa/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-ilightbox-skin-css'  href='https://frontstretch.com/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://frontstretch.com/wp-content/plugins/tablepress/css/default.css' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-custom-css'  href='https://frontstretch.com/wp-content/tablepress-custom.css' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v5.5.4 - Universal enabled - https://www.monsterinsights.com/ -->
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-34668381-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('require', 'displayfeatures');
	__gaTracker('require', 'linkid', 'linkid.js');
	__gaTracker('send','pageview');

</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript'>
/* <![CDATA[ */
var tie_insta = {"ajaxurl":"https:\/\/frontstretch.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://frontstretch.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://frontstretch.com/wp-includes/js/jquery/jquery-migrate.js'></script>
<script type='text/javascript' src='https://frontstretch.com/wp-content/plugins/taqyeem/js/tie.js'></script>
<script type='text/javascript' src='https://frontstretch.com/wp-content/plugins/wp-ajaxify-comments/js/wp-ajaxify-comments.min.js'></script>
<link rel='https://api.w.org/' href='https://frontstretch.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://frontstretch.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://frontstretch.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.2" />
<meta name="generator" content="Seriously Simple Podcasting 1.15.1" />
<link rel='shortlink' href='https://frontstretch.com/?p=129058' />
<link rel="alternate" type="application/json+oembed" href="https://frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffrontstretch.com%2F2017%2F02%2F07%2F5-cup-series-drivers-who-need-to-win-in-2017%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffrontstretch.com%2F2017%2F02%2F07%2F5-cup-series-drivers-who-need-to-win-in-2017%2F&#038;format=xml" />

<link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://frontstretch.com/feed/podcast" />

<style type="text/css">
.sfs-subscriber-count { width: 88px; overflow: hidden; height: 26px; color: #424242; font: 9px Verdana, Geneva, sans-serif; letter-spacing: 1px; }
.sfs-count { width: 86px; height: 17px; line-height: 17px; margin: 0 auto; background: #ccc; border: 1px solid #909090; border-top-color: #fff; border-left-color: #fff; }
.sfs-count span { display: inline-block; height: 11px; line-height: 12px; margin: 2px 1px 2px 2px; padding: 0 2px 0 3px; background: #e4e4e4; border: 1px solid #a2a2a2; border-bottom-color: #fff; border-right-color: #fff; }
.sfs-stats { font-size: 6px; line-height: 6px; margin: 1px 0 0 1px; word-spacing: 2px; text-align: center; text-transform: uppercase; }
</style>
<script type='text/javascript'>
/* <![CDATA[ */
var taqyeem = {"ajaxurl":"https://frontstretch.com/wp-admin/admin-ajax.php" , "your_rating":"Your Rating:"};
/* ]]> */
</script>
<style type="text/css" media="screen"> 

</style> 
<script type="text/javascript">/* <![CDATA[ */if (!window["WPAC"]) var WPAC = {};WPAC._Options = {debug:false,selectorCommentForm:"#commentform",selectorCommentsContainer:"#comments",selectorCommentPagingLinks:"#comments [class^='nav-'] a",selectorCommentLinks:"#comments a[href*=\"/comment-page-\"]",selectorRespondContainer:"#respond",selectorErrorContainer:"p:parent",popupCornerRadius:5,popupMarginTop:10,popupWidth:30,popupPadding:5,popupFadeIn:400,popupFadeOut:400,popupTimeout:3000,popupBackgroundColorLoading:"#000",popupTextColorLoading:"#fff",popupBackgroundColorSuccess:"#008000",popupTextColorSuccess:"#fff",popupBackgroundColorError:"#f00",popupTextColorError:"#fff",popupOpacity:70,popupTextAlign:"center",popupTextFontSize:"Default font size",popupZindex:1000,scrollSpeed:500,autoUpdateIdleTime:0,textPosted:"Your comment has been posted. Thank you!",textPostedUnapproved:"Your comment has been posted and is awaiting moderation. Thank you!",textReloadPage:"Reloading page. Please wait&hellip;",textPostComment:"Posting your comment. Please wait&hellip;",textRefreshComments:"Loading comments. Please wait&hellip;",textUnknownError:"Something went wrong, your comment has not been posted.",selectorPostContainer:"",commentPagesUrlRegex:"",asyncLoadTrigger:"DomReady",disableUrlUpdate:false,disableScrollToAnchor:false,disableCache:false,enableByQuery:false,commentsEnabled:true,version:"1.4.1"};WPAC._Callbacks = {"beforeSelectElements": function(dom) {},"beforeUpdateComments": function(newDom, commentUrl) {},"afterUpdateComments": function(newDom, commentUrl) {},"beforeSubmitComment": function() {}};/* ]]> */</script><link rel="shortcut icon" href="https://frontstretch.com/wp-content/uploads/2016/04/favicon-16x16.png" title="Favicon" />
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://frontstretch.com/wp-content/themes/sahifa/js/html5.js"></script>
<script src="https://frontstretch.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="https://frontstretch.com/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://frontstretch.com/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="https://frontstretch.com/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->


<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-144x144.png" />
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-120x120.png" />
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-72x72.png" />
<link rel="apple-touch-icon-precomposed" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-57x57.png" />



<style type="text/css" media="screen">

body{
	font-size : 15px;
}

.post-title{
	font-size : 40px;
}

h2.post-box-title, h2.post-box-title a{
	font-size : 26px;
}

body.single .entry, body.page .entry{
	font-size : 15px;
}

#main-nav,
.cat-box-content,
#sidebar .widget-container,
.post-listing,
#commentform {
	border-bottom-color: #ef3636;
}

.search-block .search-button,
#topcontrol,
#main-nav ul li.current-menu-item a,
#main-nav ul li.current-menu-item a:hover,
#main-nav ul li.current_page_parent a,
#main-nav ul li.current_page_parent a:hover,
#main-nav ul li.current-menu-parent a,
#main-nav ul li.current-menu-parent a:hover,
#main-nav ul li.current-page-ancestor a,
#main-nav ul li.current-page-ancestor a:hover,
.pagination span.current,
.share-post span.share-text,
.flex-control-paging li a.flex-active,
.ei-slider-thumbs li.ei-slider-element,
.review-percentage .review-item span span,
.review-final-score,
.button,
a.button,
a.more-link,
#main-content input[type="submit"],
.form-submit #submit,
#login-form .login-button,
.widget-feedburner .feedburner-subscribe,
input[type="submit"],
#buddypress button,
#buddypress a.button,
#buddypress input[type=submit],
#buddypress input[type=reset],
#buddypress ul.button-nav li a,
#buddypress div.generic-button a,
#buddypress .comment-reply-link,
#buddypress div.item-list-tabs ul li a span,
#buddypress div.item-list-tabs ul li.selected a,
#buddypress div.item-list-tabs ul li.current a,
#buddypress #members-directory-form div.item-list-tabs ul li.selected span,
#members-list-options a.selected,
#groups-list-options a.selected,
body.dark-skin #buddypress div.item-list-tabs ul li a span,
body.dark-skin #buddypress div.item-list-tabs ul li.selected a,
body.dark-skin #buddypress div.item-list-tabs ul li.current a,
body.dark-skin #members-list-options a.selected,
body.dark-skin #groups-list-options a.selected,
.search-block-large .search-button,
#featured-posts .flex-next:hover,
#featured-posts .flex-prev:hover,
a.tie-cart span.shooping-count,
.woocommerce span.onsale,
.woocommerce-page span.onsale ,
.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce-page .widget_price_filter .ui-slider .ui-slider-handle,
#check-also-close,
a.post-slideshow-next,
a.post-slideshow-prev,
.widget_price_filter .ui-slider .ui-slider-handle,
.quantity .minus:hover,
.quantity .plus:hover,
.mejs-container .mejs-controls .mejs-time-rail .mejs-time-current,
#reading-position-indicator  {
	background-color:#ef3636;
}

::-webkit-scrollbar-thumb{
	background-color:#ef3636 !important;
}

#theme-footer,
#theme-header,
.top-nav ul li.current-menu-item:before,
#main-nav .menu-sub-content ,
#main-nav ul ul,
#check-also-box {
	border-top-color: #ef3636;
}

.search-block:after {
	border-right-color:#ef3636;
}

body.rtl .search-block:after {
	border-left-color:#ef3636;
}

#main-nav ul > li.menu-item-has-children:hover > a:after,
#main-nav ul > li.mega-menu:hover > a:after {
	border-color:transparent transparent #ef3636;
}

.widget.timeline-posts li a:hover,
.widget.timeline-posts li a:hover span.tie-date {
	color: #ef3636;
}

.widget.timeline-posts li a:hover span.tie-date:before {
	background: #ef3636;
	border-color: #ef3636;
}

#order_review,
#order_review_heading {
	border-color: #ef3636;
}


body {
	background-image : url(https://frontstretch.com/wp-content/themes/sahifa/images/patterns/body-bg15.png);
	background-position: top center;
}

a:hover {
	text-decoration: underline;
}
		
body.single .post .entry a, body.page .post .entry a {
	color: #1527ed;
	text-decoration: underline;
}
		
#theme-header {
		background-image: url('https://frontstretch.com/wp-content/uploads/2016/02/FSbackground.png') !important; 
			}


.tie-cat-526 a.more-link {background-color:#9e0000;}
.tie-cat-526 .cat-box-content {border-bottom-color:#9e0000; }
			
.tie-cat-759 a.more-link {background-color:#eeff00;}
.tie-cat-759 .cat-box-content {border-bottom-color:#eeff00; }
			
.tie-cat-673 a.more-link {background-color:#00c20d;}
.tie-cat-673 .cat-box-content {border-bottom-color:#00c20d; }
			
.tie-cat-528 a.more-link {background-color:#ffdd00;}
.tie-cat-528 .cat-box-content {border-bottom-color:#ffdd00; }
			
.tie-cat-808 a.more-link {background-color:#0a009c;}
.tie-cat-808 .cat-box-content {border-bottom-color:#0a009c; }
			
#slide-out-open span,
#slide-out-open span:after,
#slide-out-open span:before {
    background: #00FF33;
}</style>

		<script type="text/javascript">
			/* <![CDATA[ */
				var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/frontstretch.com\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/frontstretch.com\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});
			/* ]]> */
		</script>
		</head>
<body id="top" class="post-template-default single single-post postid-129058 single-format-standard tribe-no-js lazy-enabled">

<div class="wrapper-outer">

	<div class="background-cover"></div>

	<aside id="slide-out">

			<div class="search-mobile">
			<form method="get" id="searchform-mobile" action="https://frontstretch.com/">
				<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
				<input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
			</form>
		</div><!-- .search-mobile /-->
	
			<div class="social-icons">
		<a class="ttip-none" title="Rss" href="https://frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a>
			</div>

	
		<div id="mobile-menu" ></div>
	</aside><!-- #slide-out /-->

		<div id="wrapper" class="boxed">
		<div class="inner-wrapper">

		<header id="theme-header" class="theme-header">
						<div id="top-nav" class="top-nav">
				<div class="container">

			
				<div class="top-menu"><ul id="menu-fs-top" class="menu"><li id="menu-item-76742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76742"><a href="https://frontstretch.com/about-us/">Welcome to Frontstretch</a></li>
<li id="menu-item-78979" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78979"><a href="https://frontstretch.com/our-staff/">Staff</a></li>
<li id="menu-item-78981" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78981"><a href="https://frontstretch.com/category/fantasy-insider/">Fantasy Insider</a></li>
<li id="menu-item-78724" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-78724"><a href="https://frontstretch.com/newsletter/">Newsletter</a>
<ul class="sub-menu">
	<li id="menu-item-78923" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78923"><a href="https://frontstretch.com/newsletter/">Sign Up For the Frontstretch Newsletter</a></li>
	<li id="menu-item-76738" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76738"><a href="https://groups.google.com/forum/#!forum/thefrontstretch" onclick="__gaTracker('send', 'event', 'outbound-widget', 'https://groups.google.com/forum/#!forum/thefrontstretch', 'Newsletter Archives');">Newsletter Archives</a></li>
</ul>
</li>
<li id="menu-item-117474" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117474"><a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" onclick="__gaTracker('send', 'event', 'outbound-widget', 'https://itunes.apple.com/us/podcast/frontstretch/id1023154421', 'Podcast');">Podcast</a></li>
<li id="menu-item-78725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78725"><a href="https://frontstretch.com/advertise-with-us/">Advertise with Us</a></li>
<li id="menu-item-78723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78723"><a href="https://frontstretch.com/jobs/">Jobs</a></li>
<li id="menu-item-76740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76740"><a href="https://frontstretch.com/about-us/contact-us/">Contact Us</a></li>
</ul></div>
						<div class="search-block">
						<form method="get" id="searchform-header" action="https://frontstretch.com/">
							<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
							<input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
						</form>
					</div><!-- .search-block /-->
			<div class="social-icons">
		<a class="ttip-none" title="Rss" href="https://frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a>
			</div>

	
	
				</div><!-- .container /-->
			</div><!-- .top-menu /-->
			
		<div class="header-content">

					<a id="slide-out-open" class="slide-out-open" href="#"><span></span></a>
		
			<div class="logo" style=" margin-top:15px; margin-bottom:15px;">
			<h2>								<a title="Frontstretch" href="https://frontstretch.com/">
					<img src="https://frontstretch.com/wp-content/uploads/2016/03/FS-Logo.png" alt="Frontstretch"  /><strong>Frontstretch Best seat at the track, best view on the web!</strong>
				</a>
			</h2>			</div><!-- .logo /-->
						<div class="clear"></div>

		</div>
													<nav id="main-nav" class="fixed-enabled">
				<div class="container">

				
					<div class="main-menu"><ul id="menu-fs-mega" class="menu"><li id="menu-item-114497" class="main-nav ul limenu-item-home a menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-114497"><a href="https://frontstretch.com">Home</a></li>
<li id="menu-item-114537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114537 mega-menu mega-recent-featured "><a href="https://frontstretch.com/category/cup-series/">Cup Series</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">
<div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/26/friday-faceoff-how-about-all-these-changes/" title="Friday Faceoff: How About All These Changes?"><img src="https://frontstretch.com/wp-content/uploads/2016/09/2016-Chicago-CUP-CArl-Edwards-Nigel-Kinrade-NKP-660x330.jpg" width="660" height="330" alt="Friday Faceoff: How About All These Changes?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/26/friday-faceoff-how-about-all-these-changes/" title="Friday Faceoff: How About All These Changes?">Friday Faceoff: How About All These Changes?</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>January 26, 2017</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/26/the-frontstretch-5-2017-nascar-developing-storylines/" title="The Frontstretch 5: 2017 NASCAR Developing Storylines"><img src="https://frontstretch.com/wp-content/uploads/2016/07/gordon-and-stewart-indy-110x75.jpg" width="110" height="75" alt="The Frontstretch 5: 2017 NASCAR Developing Storylines" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/26/the-frontstretch-5-2017-nascar-developing-storylines/" title="The Frontstretch 5: 2017 NASCAR Developing Storylines">The Frontstretch 5: 2017 NASCAR Developing Storylines</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>January 26, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/25/matt-dibenedetto-confident-in-move-to-go-fas-racing/" title="Matt DiBenedetto Confident in Move to Go FAS Racing"><img src="https://frontstretch.com/wp-content/uploads/2017/01/dibene-110x75.jpg" width="110" height="75" alt="Matt DiBenedetto Confident in Move to Go FAS Racing" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/25/matt-dibenedetto-confident-in-move-to-go-fas-racing/" title="Matt DiBenedetto Confident in Move to Go FAS Racing">Matt DiBenedetto Confident in Move to Go FAS Racing</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>January 25, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/24/beyond-the-cockpit-landon-cassill-would-rather-be-overrated-than-underrated/" title="Beyond the Cockpit: Landon Cassill Would Rather Be Overrated Than Underrated"><img src="https://frontstretch.com/wp-content/uploads/2016/07/2016-Pocono-I-CUP-Landon-Cassill-Looking-Down-Anthony-Lumbis-Sr.-110x75.jpg" width="110" height="75" alt="Beyond the Cockpit: Landon Cassill Would Rather Be Overrated Than Underrated" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/24/beyond-the-cockpit-landon-cassill-would-rather-be-overrated-than-underrated/" title="Beyond the Cockpit: Landon Cassill Would Rather Be Overrated Than Underrated">Beyond the Cockpit: Landon Cassill Would Rather Be Overrated Than Underrated</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>January 24, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/24/ty-dillon-its-nice-to-have-my-own-identity-with-germain-racing/" title="Ty Dillon: &#8216;It&#8217;s Nice to Have My Own Identity&#8217; with Germain Racing"><img src="https://frontstretch.com/wp-content/uploads/2017/01/tyd-110x75.jpg" width="110" height="75" alt="Ty Dillon: &#8216;It&#8217;s Nice to Have My Own Identity&#8217; with Germain Racing" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/24/ty-dillon-its-nice-to-have-my-own-identity-with-germain-racing/" title="Ty Dillon: &#8216;It&#8217;s Nice to Have My Own Identity&#8217; with Germain Racing">Ty Dillon: &#8216;It&#8217;s Nice to Have My Own Identity&#8217; with Germain Racing</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>January 24, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/24/erik-jones-adapting-to-format-changes-up-the-nascar-ladder/" title="Erik Jones Adapting to Format Changes While Climbing NASCAR Ladder"><img src="https://frontstretch.com/wp-content/uploads/2017/01/EJ-110x75.jpg" width="110" height="75" alt="Erik Jones Adapting to Format Changes While Climbing NASCAR Ladder" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/24/erik-jones-adapting-to-format-changes-up-the-nascar-ladder/" title="Erik Jones Adapting to Format Changes While Climbing NASCAR Ladder">Erik Jones Adapting to Format Changes While Climbing NASCAR Ladder</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>January 24, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/24/holding-a-pretty-wheel-nascars-game-changer-that-doesnt-change-the-game/" title="Holding a Pretty Wheel: NASCAR&#8217;s Game-Changer That Doesn&#8217;t Change the Game"><img src="https://frontstretch.com/wp-content/uploads/2016/11/logano-phoenix-110x75.jpg" width="110" height="75" alt="Holding a Pretty Wheel: NASCAR&#8217;s Game-Changer That Doesn&#8217;t Change the Game" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/24/holding-a-pretty-wheel-nascars-game-changer-that-doesnt-change-the-game/" title="Holding a Pretty Wheel: NASCAR&#8217;s Game-Changer That Doesn&#8217;t Change the Game">Holding a Pretty Wheel: NASCAR&#8217;s Game-Changer That Doesn&#8217;t Change the Game</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>January 24, 2017</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-114540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114540 mega-menu mega-recent-featured "><a href="https://frontstretch.com/category/xfinity/">XFINITY</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">
<div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2017/02/06/ben-kennedy-joins-richard-childress-racing-for-nine-xfinity-series-races-in-2017/" title="Ben Kennedy Joins Richard Childress Racing for 9 XFINITY Series Races in 2017"><img src="https://frontstretch.com/wp-content/uploads/2016/12/ben-kennedy-640x330.jpg" width="660" height="330" alt="Ben Kennedy Joins Richard Childress Racing for 9 XFINITY Series Races in 2017" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2017/02/06/ben-kennedy-joins-richard-childress-racing-for-nine-xfinity-series-races-in-2017/" title="Ben Kennedy Joins Richard Childress Racing for 9 XFINITY Series Races in 2017">Ben Kennedy Joins Richard Childress Racing for 9 XFINITY Series Races in 2017</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>February 6, 2017</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/26/beyond-the-cockpit-brennan-poole-gunning-for-championship-run-with-chip-ganassi-racing/" title="Beyond the Cockpit: Brennan Poole Gunning for Championship Run with Chip Ganassi Racing"><img src="https://frontstretch.com/wp-content/uploads/2017/01/brennan-poole-richmond-110x75.jpg" width="110" height="75" alt="Beyond the Cockpit: Brennan Poole Gunning for Championship Run with Chip Ganassi Racing" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/26/beyond-the-cockpit-brennan-poole-gunning-for-championship-run-with-chip-ganassi-racing/" title="Beyond the Cockpit: Brennan Poole Gunning for Championship Run with Chip Ganassi Racing">Beyond the Cockpit: Brennan Poole Gunning for Championship Run with Chip Ganassi Racing</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>January 26, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/17/jj-yeley-not-looking-to-retire-anytime-soon/" title="JJ Yeley Not Looking to Retire Anytime Soon"><img src="https://frontstretch.com/wp-content/uploads/2016/11/yelely-110x75.jpg" width="110" height="75" alt="JJ Yeley Not Looking to Retire Anytime Soon" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/17/jj-yeley-not-looking-to-retire-anytime-soon/" title="JJ Yeley Not Looking to Retire Anytime Soon">JJ Yeley Not Looking to Retire Anytime Soon</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>January 17, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/12/elliott-sadler-thankful-to-race-for-jr-motorsports-late-in-his-career/" title="Elliott Sadler Thankful to Race for JR Motorsports Late in His Career"><img src="https://frontstretch.com/wp-content/uploads/2016/09/2016-Chicago-NXS-Elliott-Sadler-car-Brett-Moist-NKP-110x75.jpg" width="110" height="75" alt="Elliott Sadler Thankful to Race for JR Motorsports Late in His Career" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/12/elliott-sadler-thankful-to-race-for-jr-motorsports-late-in-his-career/" title="Elliott Sadler Thankful to Race for JR Motorsports Late in His Career">Elliott Sadler Thankful to Race for JR Motorsports Late in His Career</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>January 12, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/12/20/brennan-poole-to-return-to-chip-ganassi-racing/" title="Brennan Poole to Return to Chip Ganassi Racing"><img src="https://frontstretch.com/wp-content/uploads/2016/11/poole-110x75.jpg" width="110" height="75" alt="Brennan Poole to Return to Chip Ganassi Racing" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/12/20/brennan-poole-to-return-to-chip-ganassi-racing/" title="Brennan Poole to Return to Chip Ganassi Racing">Brennan Poole to Return to Chip Ganassi Racing</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 20, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/12/18/william-byron-excited-about-2017-with-jr-motorsports/" title="William Byron &#8216;Excited&#8217; About 2017 with JR Motorsports"><img src="https://frontstretch.com/wp-content/uploads/2016/07/william-byron-kyle-busch-110x75.png" width="110" height="75" alt="William Byron &#8216;Excited&#8217; About 2017 with JR Motorsports" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/12/18/william-byron-excited-about-2017-with-jr-motorsports/" title="William Byron &#8216;Excited&#8217; About 2017 with JR Motorsports">William Byron &#8216;Excited&#8217; About 2017 with JR Motorsports</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 18, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/12/09/daniel-suarez-nascar-role-model-for-mexico-latin-america/" title="Daniel Suarez: NASCAR Role Model For Mexico, Latin America"><img src="https://frontstretch.com/wp-content/uploads/2016/11/suarez-110x75.jpg" width="110" height="75" alt="Daniel Suarez: NASCAR Role Model For Mexico, Latin America" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/12/09/daniel-suarez-nascar-role-model-for-mexico-latin-america/" title="Daniel Suarez: NASCAR Role Model For Mexico, Latin America">Daniel Suarez: NASCAR Role Model For Mexico, Latin America</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 9, 2016</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-114542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-114542 mega-menu mega-recent-featured "><a href="https://frontstretch.com/category/truck-series/">Truck Series</a>
<div class="mega-menu-block menu-sub-content">

<ul class="mega-recent-featured-list sub-list">
	<li id="menu-item-114644" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114644"><a href="https://frontstretch.com/cwts-schedule/">2016 Schedule</a></li>
	<li id="menu-item-114645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114645"><a href="https://frontstretch.com/category/news/truck-series-news/">News</a></li>
	<li id="menu-item-114648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114648"><a href="https://frontstretch.com/category/truck-series/truckin-thursdays/">Commentary</a></li>
	<li id="menu-item-114647" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114647"><a href="https://frontstretch.com/category/truck-series/truck-results/">Race Results</a></li>
	<li id="menu-item-114646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114646"><a href="https://frontstretch.com/category/truck-series/tracking-the-trucks-race-report/">Race Report</a></li>
</ul>

<div class="mega-menu-content">
<div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2017/02/03/beyond-the-cockpit-noah-gragson-energized-for-first-year-with-kyle-busch-motorsports/" title="Beyond the Cockpit: Noah Gragson Energized Joining Trucks, Kyle Busch"><img src="https://frontstretch.com/wp-content/uploads/2017/01/noah-gragson-homestead-640x330.jpg" width="660" height="330" alt="Beyond the Cockpit: Noah Gragson Energized Joining Trucks, Kyle Busch" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2017/02/03/beyond-the-cockpit-noah-gragson-energized-for-first-year-with-kyle-busch-motorsports/" title="Beyond the Cockpit: Noah Gragson Energized Joining Trucks, Kyle Busch">Beyond the Cockpit: Noah Gragson Energized Joining Trucks, Kyle Busch</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>February 3, 2017</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/19/parker-kligerman-to-compete-for-henderson-motorsports-expand-role-with-nbc-sports-in-2017/" title="Parker Kligerman to Compete for Henderson Motorsports, Expand Role with NBC Sports in 2017"><img src="https://frontstretch.com/wp-content/uploads/2017/01/parker-kligerman-110x75.jpg" width="110" height="75" alt="Parker Kligerman to Compete for Henderson Motorsports, Expand Role with NBC Sports in 2017" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2017/01/19/parker-kligerman-to-compete-for-henderson-motorsports-expand-role-with-nbc-sports-in-2017/" title="Parker Kligerman to Compete for Henderson Motorsports, Expand Role with NBC Sports in 2017">Parker Kligerman to Compete for Henderson Motorsports, Expand Role with NBC Sports in 2017</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>January 19, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/12/29/rick-ware-racing-truck-series-2017/" title="Rick Ware Racing Move to Truck Series, Shut Down XFINITY Program"><img src="https://frontstretch.com/wp-content/uploads/2016/12/cody-ware-110x75.jpg" width="110" height="75" alt="Rick Ware Racing Move to Truck Series, Shut Down XFINITY Program" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/12/29/rick-ware-racing-truck-series-2017/" title="Rick Ware Racing Move to Truck Series, Shut Down XFINITY Program">Rick Ware Racing Move to Truck Series, Shut Down XFINITY Program</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 29, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/12/22/ben-kennedy-there-are-different-things-i-wish-i-spent-more-times-doing/" title="Ben Kennedy: There Are Different Things I Wish I Spent More Time Doing"><img src="https://frontstretch.com/wp-content/uploads/2016/12/kennedy-110x75.jpg" width="110" height="75" alt="Ben Kennedy: There Are Different Things I Wish I Spent More Time Doing" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/12/22/ben-kennedy-there-are-different-things-i-wish-i-spent-more-times-doing/" title="Ben Kennedy: There Are Different Things I Wish I Spent More Time Doing">Ben Kennedy: There Are Different Things I Wish I Spent More Time Doing</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 22, 2016</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-114549" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114549 mega-menu mega-recent-featured "><a href="https://frontstretch.com/category/nhra/">NHRA</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">
<div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/11/16/nitro-shots-final-shot/" title="Nitro Shots: Final Shot"><img src="https://frontstretch.com/wp-content/uploads/2016/11/NHRA-2016-Connie-Kalitta-Lifetime-Achievement-Award-courtesy-Kalitta-Motorsports-660x330.jpg" width="660" height="330" alt="Nitro Shots: Final Shot" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/11/16/nitro-shots-final-shot/" title="Nitro Shots: Final Shot">Nitro Shots: Final Shot</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>November 16, 2016</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/11/09/nitro-shots-banner-year/" title="Nitro Shots: Banner Year?"><img src="https://frontstretch.com/wp-content/uploads/2016/11/NHRA-2016-Pro-Mod-champion-Rickie-Smith-courtesy-NHRA-110x75.jpg" width="110" height="75" alt="Nitro Shots: Banner Year?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/11/09/nitro-shots-banner-year/" title="Nitro Shots: Banner Year?">Nitro Shots: Banner Year?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 9, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/11/03/nitro-shots-one-last-hurrah/" title="Nitro Shots: One Last Hurrah"><img src="https://frontstretch.com/wp-content/uploads/2016/11/NHRA-2016-Las-Vegas-Antron-Brown-champion-courtesy-NHRA-110x75.jpg" width="110" height="75" alt="Nitro Shots: One Last Hurrah" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/11/03/nitro-shots-one-last-hurrah/" title="Nitro Shots: One Last Hurrah">Nitro Shots: One Last Hurrah</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 3, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/11/01/the-frontstretch-5-memorable-championship-battles/" title="The Frontstretch 5: Memorable Championship Battles"><img src="https://frontstretch.com/wp-content/uploads/2016/06/2106-Sonoma-CUP-pack-racing-Nigel-Kinrade-NKP-110x75.jpg" width="110" height="75" alt="The Frontstretch 5: Memorable Championship Battles" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/11/01/the-frontstretch-5-memorable-championship-battles/" title="The Frontstretch 5: Memorable Championship Battles">The Frontstretch 5: Memorable Championship Battles</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 1, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/10/27/nitro-shots-the-nhras-youth-movement/" title="Nitro Shots: The NHRA&#8217;s Youth Movement"><img src="https://frontstretch.com/wp-content/uploads/2016/03/NHRA-2016-Gainesville-Brittany-Force-John-Force-Wally-courtesy-NHRA-Media-55x55.jpg" width="110" height="75" alt="Nitro Shots: The NHRA&#8217;s Youth Movement" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/10/27/nitro-shots-the-nhras-youth-movement/" title="Nitro Shots: The NHRA&#8217;s Youth Movement">Nitro Shots: The NHRA&#8217;s Youth Movement</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 27, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/10/13/nitro-shots-whats-so-scary-about-a-couple-of-cars/" title="Nitro Shots: What’s So Scary About a Couple of Cars?"><img src="https://frontstretch.com/wp-content/uploads/2016/07/NHRA-2016-Chicago-Antron-Brown-car-courtesy-NHRA-110x75.jpg" width="110" height="75" alt="Nitro Shots: What’s So Scary About a Couple of Cars?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/10/13/nitro-shots-whats-so-scary-about-a-couple-of-cars/" title="Nitro Shots: What’s So Scary About a Couple of Cars?">Nitro Shots: What’s So Scary About a Couple of Cars?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 13, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/10/06/nitro-shots-halfway-to-a-championship/" title="Nitro Shots: Halfway to a Championship"><img src="https://frontstretch.com/wp-content/uploads/2016/10/NHRA-2016-Alexis-DeJoria-pink-car-on-track-courtesy-Gary-Natase-Photography-110x75.jpg" width="110" height="75" alt="Nitro Shots: Halfway to a Championship" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/10/06/nitro-shots-halfway-to-a-championship/" title="Nitro Shots: Halfway to a Championship">Nitro Shots: Halfway to a Championship</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 6, 2016</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-114548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114548 mega-menu mega-recent-featured "><a href="https://frontstretch.com/category/indycar/">IndyCar</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">
<div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/11/01/the-frontstretch-5-memorable-championship-battles/" title="The Frontstretch 5: Memorable Championship Battles"><img src="https://frontstretch.com/wp-content/uploads/2016/06/2106-Sonoma-CUP-pack-racing-Nigel-Kinrade-NKP-660x330.jpg" width="660" height="330" alt="The Frontstretch 5: Memorable Championship Battles" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/11/01/the-frontstretch-5-memorable-championship-battles/" title="The Frontstretch 5: Memorable Championship Battles">The Frontstretch 5: Memorable Championship Battles</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>November 1, 2016</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/10/12/sebastien-bourdais-confirmed-at-dale-coyne-racing-for-2017/" title="Sebastien Bourdais Confirmed at Dale Coyne Racing for 2017"><img src="https://frontstretch.com/wp-content/uploads/2015/06/JGS_7403-1-55x55.jpg" width="110" height="75" alt="Sebastien Bourdais Confirmed at Dale Coyne Racing for 2017" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/10/12/sebastien-bourdais-confirmed-at-dale-coyne-racing-for-2017/" title="Sebastien Bourdais Confirmed at Dale Coyne Racing for 2017">Sebastien Bourdais Confirmed at Dale Coyne Racing for 2017</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 12, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/10/05/josef-newgarden-moves-to-team-penske-for-2017/" title="Josef Newgarden Moves to Team Penske for 2017"><img src="https://frontstretch.com/wp-content/uploads/2016/06/16C_1705-1-110x75.jpg" width="110" height="75" alt="Josef Newgarden Moves to Team Penske for 2017" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/10/05/josef-newgarden-moves-to-team-penske-for-2017/" title="Josef Newgarden Moves to Team Penske for 2017">Josef Newgarden Moves to Team Penske for 2017</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 5, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/09/20/5-points-to-ponder-chase-ing-the-chase-at-hendrick-motorsports/" title="5 Points to Ponder: &#8220;Chase&#8221;-ing The Chase at Hendrick Motorsports"><img src="https://frontstretch.com/wp-content/uploads/2016/07/2016-Loudon-I-CUP-Chase-Elliott-Jimmie-Johnson-Nigel-Kinrade-NKP-110x75.jpg" width="110" height="75" alt="5 Points to Ponder: &#8220;Chase&#8221;-ing The Chase at Hendrick Motorsports" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/09/20/5-points-to-ponder-chase-ing-the-chase-at-hendrick-motorsports/" title="5 Points to Ponder: &#8220;Chase&#8221;-ing The Chase at Hendrick Motorsports">5 Points to Ponder: &#8220;Chase&#8221;-ing The Chase at Hendrick Motorsports</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 20, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/09/18/helio-castroneves-craving-end-to-winless-drought/" title="Helio Castroneves Craving End to Winless Drought"><img src="https://frontstretch.com/wp-content/uploads/2016/09/16C_0170-1-110x75.jpg" width="110" height="75" alt="Helio Castroneves Craving End to Winless Drought" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/09/18/helio-castroneves-craving-end-to-winless-drought/" title="Helio Castroneves Craving End to Winless Drought">Helio Castroneves Craving End to Winless Drought</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 18, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/09/15/4-burning-questions-should-we-expect-the-unexpected-at-chicagoland/" title="4 Burning Questions: Should We Expect the Unexpected at Chicagoland?"><img src="https://frontstretch.com/wp-content/uploads/2016/09/garv-110x75.jpg" width="110" height="75" alt="4 Burning Questions: Should We Expect the Unexpected at Chicagoland?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/09/15/4-burning-questions-should-we-expect-the-unexpected-at-chicagoland/" title="4 Burning Questions: Should We Expect the Unexpected at Chicagoland?">4 Burning Questions: Should We Expect the Unexpected at Chicagoland?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 15, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://frontstretch.com/2016/09/15/happiness-is-chase-clarity-champion/" title="Happiness Is&#8230; Chase, Clarity &#038; Champion"><img src="https://frontstretch.com/wp-content/uploads/2016/07/2016-Kentucky-CUP-Tony-Stewart-helmet-Russell-LaBounty-NKP-110x75.jpg" width="110" height="75" alt="Happiness Is&#8230; Chase, Clarity &#038; Champion" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://frontstretch.com/2016/09/15/happiness-is-chase-clarity-champion/" title="Happiness Is&#8230; Chase, Clarity &#038; Champion">Happiness Is&#8230; Chase, Clarity &#038; Champion</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 15, 2016</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-114559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114559"><a href="https://frontstretch.com/category/formula-one/">Formula One</a></li>
<li id="menu-item-114556" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-114556"><a href="https://frontstretch.com/sports-cars/">Sports Cars</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-114558" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114558"><a href="https://frontstretch.com/category/imsa/">IMSA</a></li>
</ul>
</li>
<li id="menu-item-114550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114550"><a href="https://frontstretch.com/tv-schedule/">TV Schedule</a></li>
</ul></div>										<a href="https://frontstretch.com/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a>
					
					
				</div>
			</nav><!-- .main-nav /-->
					</header><!-- #header /-->

	
	
	<div id="main-content" class="container">
	
	
	
	
	
	<div class="content">

		
		<div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://frontstretch.com">Home</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://frontstretch.com/category/news/">News</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://frontstretch.com/category/news/cup-series-news/">Cup Series News</a></span> <span class="delimiter">/</span> <span class="current">5 Cup Series Drivers Who Need to Win in 2017</span></div>
		

		
		<article class="post-listing post-129058 post type-post status-publish format-standard has-post-thumbnail  category-cup-series-news category-dustin-albino tag-clint-bowyer tag-danica-patrick tag-erik-jones tag-kasey-kahne tag-ricky-stenhouse-jr" id="the-post">
			
			<div class="single-post-thumb">
			<img width="496" height="330" src="https://frontstretch.com/wp-content/uploads/2015/09/2015-Chicago-CUP-Clint-Bowyer-Danica-Patrick-CIA-660x439.jpg" class="attachment-slider size-slider wp-post-image" alt="" srcset="https://frontstretch.com/wp-content/uploads/2015/09/2015-Chicago-CUP-Clint-Bowyer-Danica-Patrick-CIA-660x439.jpg 660w, https://frontstretch.com/wp-content/uploads/2015/09/2015-Chicago-CUP-Clint-Bowyer-Danica-Patrick-CIA-150x100.jpg 150w, https://frontstretch.com/wp-content/uploads/2015/09/2015-Chicago-CUP-Clint-Bowyer-Danica-Patrick-CIA-300x200.jpg 300w, https://frontstretch.com/wp-content/uploads/2015/09/2015-Chicago-CUP-Clint-Bowyer-Danica-Patrick-CIA.jpg 720w" sizes="(max-width: 496px) 100vw, 496px" />		</div>
	
		<div class="single-post-caption">(Photo: CIA Stock Photo, Inc. ©2015)­­</div> 


			<div class="post-inner">

							<h1 class="name post-title entry-title"><span itemprop="name">5 Cup Series Drivers Who Need to Win in 2017</span></h1>

						
<p class="post-meta">
		
	<span class="post-meta-author"><i class="fa fa-user"></i><a href="https://frontstretch.com/author/dustin-albino/" title="">Dustin Albino </a></span>
	
		
	<span class="tie-date"><i class="fa fa-clock-o"></i>February 7, 2017</span>	
	<span class="post-cats"><i class="fa fa-folder"></i><a href="https://frontstretch.com/category/news/cup-series-news/" rel="category tag">Cup Series News</a>, <a href="https://frontstretch.com/category/dustin-albino/" rel="category tag">Dustin Albino</a></span>
	
	<span class="post-comments"><i class="fa fa-comments"></i><a href="https://frontstretch.com/2017/02/07/5-cup-series-drivers-who-need-to-win-in-2017/#comments">3 Comments</a></span>
</p>
<div class="clear"></div>
			
				<div class="entry">
					
					
					<p>When NASCAR announced changes to the race format late last month, it made consistency relevant again. Winning is still going to have its virtues, including an automatic playoff berth, but in the grand scheme of things, it&#8217;s not the end-all, be-all it often has been.</p>
<p>Like other changes NASCAR has made in the past, the best organizations will likely find a way to beat the system early on. It&#8217;s likely that not much will change as there were only 13 race winners last season. It has the potential to be the same faces in the same place: Victory Lane.</p>
<p>Every driver would like to win a race as NASCAR is arguably the most competitive sport, but certain drivers need a victory, and do it at any cost.</p>
<h2><strong>Clint Bowyer</strong></h2>
<p>Seventeen months ago, it was confirmed that <a href="/tag/clint-bowyer">Clint Bowyer</a> would be taking over the No. 14 car for Tony Stewart following his retirement tour in 2016. During the waiting process, it has been the lowest point of the Kansas native&#8217;s career as he comes off a season in which he tallied three top-10 finishes, by far the worst mark in his career. His previous low was 11 in 2007 during his rookie season for Richard Childress Racing.</p>
<p>But change is something to which Bowyer is accustomed. After all, 2017 will mark the third straight season in which he has competed with a different race team and car manufacturer.</p>
<p>It&#8217;s hard to believe that it&#8217;s been nearly five years since his last victory at Charlotte Motor Speedway, a season in which he had a career-high three victories. Despite finishing running-up in the championship that season, things have never been the same for Bowyer, which makes 2017 a crucial season. He has been placed in one of the top cars with one of the top teams in NASCAR. Working with former Cup Series champions <a href="/tag/kevin-harvick">Kevin Harvick</a> and <a href="/tag/kurt-busch">Kurt Busch</a> should enhance his chances of being consistent yet again, something for which the 37-year-old is known.</p>
<h2><strong>Danica Patrick</strong></h2>
<p>Sticking with the Stewart-Haas Racing theme, <a href="/tag/danica-patrick">Danica Patrick</a> is in must-win season. She is nearing the end of her contract with her current race team and is also in a precarious situation regarding sponsorship, as <a href="http://bigstory.ap.org/article/b2fe23f4066b4c129be327c7bb5084dc/apnewsbreak-danica-patricks-sponsor-sued-racing-team" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://bigstory.ap.org/article/b2fe23f4066b4c129be327c7bb5084dc/apnewsbreak-danica-patricks-sponsor-sued-racing-team', 'The Associated Press');"><em>The Associated Press</em></a> reporteded late last week that the team is suing Nature&#8217;s Bakery, which served as the primary sponsor for the No. 10 car in 2016.</p>
<p>This comes two years after GoDaddy.com announced it would end its partnership, which dates back to her IndyCar days, with Patrick.</p>
<p>Is performance the issue? Quite possibly. In four full-time seasons with SHR, Patrick has six top-10 finishes, with a career-best sixth-place finish at Atlanta Motor Speedway in 2014. In the 144 races over the last four seasons, she has 16 DNFs, among the highest of full-time competitors.</p>
<p>Patrick has seemed to be most competitive on restrictor plate tracks, including sitting on the pole of the 2013 Daytona 500. However, in 17 career plate races, she has a pair of eighth-place finishes at Daytona International Speedway and in 2016 didn&#8217;t finish higher than 20th at Daytona or Talladega Superspeedway.</p>
<p>Besides the plate tracks, nothing has looked too promising, at least enough to challenge for wins. And victories might be what it takes for Patrick to further her career and sign another contract with either SHR or another race team.</p>
<h2><strong>Kasey Kahne</strong></h2>
<p>The same race at Atlanta in which Patrick finished sixth was the last time <a href="/tag/kasey-kahne">Kasey Kahne</a> ended a race in Victory Lane.</p>
<p>Five years have come and gone, with Kahne piloting the No. 5 car for Hendrick Motorsports in that span of time, during which he has five victories. However, in each of the past two seasons, the Keith Rodden-led race team has come up short of making it to the playoffs.</p>
<p>In 2014, Kahne has had only three top-five finishes in each of the last three seasons, compared to his 23 combined in his first two seasons in the Chevrolet stable. Midway through 2016, Kahne admitted that he felt like the team had hit &#8220;rock bottom&#8221; and that it wasn&#8217;t fun going to the racetrack any longer.</p>
<p>But though he missed the Chase, the team was hitting on all seven cylinders early on in the playoffs. In the last 12 races of 2016, Kahne had seven top-10 finishes, finishing third at Charlotte Motor Speedway in October, a season-best. That said, in the 36-race season, the No. 5 failed to lead a single lap.</p>
<p>Everyone knows that Kahne can win; he&#8217;s done so 17 times in his career. But going into a contract season, 2017 is the biggest year of his tenure at HMS as the team has <a href="/tag/william-byron">William Byron</a>, among others, waiting for an opportunity in the Cup Series.</p>
<h2><strong>Ricky Stenhouse Jr.</strong></h2>
<p>There is no doubt about it: Ricky Stenhouse Jr. didn&#8217;t walk into Roush Fenway Racing under the best circumstances.</p>
<p>After winning back-to-back XFINITY Series championships with the organization, he replaced a Cup Series veteran, <a href="/tag/matt-kenseth">Matt Kenseth</a>, in the No. 17 car. And during his four full seasons in the Cup Series, expectations were set much higher than what has been delivered, but it could be argued that it&#8217;s not entirely his fault.</p>
<p>Over the last three seasons, RFR has been in a bit of rebuilding stage, even more so heading into 2017 after losing Greg Biffle, who had spent his entire NASCAR career with Jack Roush&#8217;s team. The struggles of the team now falls on <a href="/tag/trevor-bayne">Trevor Bayne</a> and Stenhouse&#8217;s shoulders, as the once five-car organization has shrunk down to two Cup teams.</p>
<p>In 148 career starts, Stenhouse has 17 top-10 finishes, including a career-high six in 2016. The peak of his 2016 came at Bristol Motor Speedway in August, finishing second to Kevin Harvick.</p>
<p>Throughout his career, Stenhouse has excelled at Bristol with an average finish of 10.6, his best at any track. He&#8217;s also performed well in plate races; Stenhouse finished in the top five in two of the four plate races in 2016. He also had a top-five finish at Auto Club Speedway in March.</p>
<p>However, in his four seasons, Stenhouse has never finished above 19th in the championship standings. He will likely need to outperform the equipment again this year, though RFR dropping to two cars could work wonders for the organization.</p>
<h2>Erik Jones</h2>
<p>He&#8217;s the most surprising on the list for sure, but think about it this way: <a href="/tag/erik-jones">Erik Jones</a> has been labeled the next big star of NASCAR, and there are expectations that run with that distinction.</p>
<p>Jones enters his rookie season in the Cup Series, competing with Furniture Row Racing, which had four victories in 2016 with <a href="/tag/martin-truex-jr">Martin Truex Jr.</a> Adding Joe Gibbs Racing to the mix, Toyota won 16 races in 2016, the most of the three manufactures.</p>
<p>Who would have though even two years ago that Furniture Row Racing would have two competitive teams in the Cup Series? Yes, Truex won at Pocono Raceway in 2015 and made the Championship 4 at Homestead-Miami Speedway, but this is an old-school way of becoming a top organization.</p>
<p>Jones has limited experience in the Cup Series, competing in three races in 2015, subbing for Kyle Busch and Matt Kenseth. But the 20-year-old has had high praise from just about everyone around the sport.</p>
<p>Consistency is something that Jones&#8217; XFINITY Series race team could not find in 2016. It led to him finishing fourth in the championship, despite having the most victories of XFINITY Series regulars. The poor consistency throughout the playoffs almost disallowed him from competing for the championship, having to race his way in at Phoenix International Raceway last fall.</p>
<p>The talent is there, but with the enhancement to the point standings, Jones needs to be consistent in order to win a race in his rookie season.</p>
					
									</div><!-- .entry /-->


				<div class="share-post">
	<span class="share-text">Share</span>
	
		<ul class="flat-social">	
			<li><a href="http://www.facebook.com/sharer.php?u=https://frontstretch.com/?p=129058" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li>
		
			<li><a href="https://twitter.com/intent/tweet?text=5+Cup+Series+Drivers+Who+Need+to+Win+in+2017&url=https://frontstretch.com/?p=129058" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li>
				<li><a href="https://plusone.google.com/_/+1/confirm?hl=en&amp;url=https://frontstretch.com/?p=129058&amp;name=5+Cup+Series+Drivers+Who+Need+to+Win+in+2017" class="social-google-plus" rel="external" target="_blank"><i class="fa fa-google-plus"></i> <span>Google +</span></a></li>
				<li><a href="http://www.stumbleupon.com/submit?url=https://frontstretch.com/?p=129058&title=5+Cup+Series+Drivers+Who+Need+to+Win+in+2017" class="social-stumble" rel="external" target="_blank"><i class="fa fa-stumbleupon"></i> <span>Stumbleupon</span></a></li>
				<li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https://frontstretch.com/?p=129058&title=5+Cup+Series+Drivers+Who+Need+to+Win+in+2017" class="social-linkedin" rel="external" target="_blank"><i class="fa fa-linkedin"></i> <span>LinkedIn</span></a></li>
				<li><a href="http://pinterest.com/pin/create/button/?url=https://frontstretch.com/?p=129058&amp;description=5+Cup+Series+Drivers+Who+Need+to+Win+in+2017&amp;media=https://frontstretch.com/wp-content/uploads/2015/09/2015-Chicago-CUP-Clint-Bowyer-Danica-Patrick-CIA-660x439.jpg" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li>
		</ul>
		<div class="clear"></div>
</div> <!-- .share-post -->				<div class="clear"></div>
			</div><!-- .post-inner -->

			<script type="application/ld+json">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</script>
		</article><!-- .post-listing -->
		<p class="post-tag">Tags <a href="https://frontstretch.com/tag/clint-bowyer/" rel="tag">Clint Bowyer</a> <a href="https://frontstretch.com/tag/danica-patrick/" rel="tag">Danica Patrick</a> <a href="https://frontstretch.com/tag/erik-jones/" rel="tag">Erik Jones</a> <a href="https://frontstretch.com/tag/kasey-kahne/" rel="tag">Kasey Kahne</a> <a href="https://frontstretch.com/tag/ricky-stenhouse-jr/" rel="tag">Ricky Stenhouse Jr.</a></p>

		
				<section id="author-box">
			<div class="block-head">
				<h3>About Dustin Albino </h3><div class="stripe-line"></div>
			</div>
			<div class="post-listing">
				<div class="author-bio">
	<div class="author-avatar">
		<img src="https://frontstretch.com/wp-content/uploads/2016/07/Dustin-and-Dale-150x117.jpg" width="90" height="70" alt="Dustin Albino" class="avatar avatar-90 wp-user-avatar wp-user-avatar-90 alignnone photo" />	</div><!-- #author-avatar -->
			<div class="author-description">
						Dustin joined the Frontstretch team at the beginning of the 2016 season. It's his second year covering the sport that he grew up loving. His dream was to one day be a NASCAR journalist, thus why he is currently attending Ithaca College in Ithaca, N.Y. He grew up in the Finger Lakes region of New York, hoping that NASCAR would be in his future. 
You can also view some of Dustin's work on SpeedwayDigest.com, where he spent the 2015 season.		</div><!-- #author-description -->
			<div class="author-social flat-social">
									<a class="social-facebook" target="_blank" href="https://www.facebook.com/Dustin-Albino-1649260695340254/?ref=aymt_homepage_panel"><i class="fa fa-facebook"></i></a>
									<a class="social-twitter" target="_blank" href="http://twitter.com/@DustinAlbino"><i class="fa fa-twitter"></i><span> @@DustinAlbino</span></a>
												<a class="social-linkedin" target="_blank" href="https://www.linkedin.com/in/dustin-albino-4bb934105?trk=nav_responsive_tab_profile"><i class="fa fa-linkedin"></i></a>
																					<a class="social-instagram" target="_blank" href="https://www.instagram.com/dustin_albino/?hl=en"><i class="fa fa-instagram"></i></a>
					</div>
		<div class="clear"></div>
</div>
				</div>
		</section><!-- #author-box -->
		

				<div class="post-navigation">
			<div class="post-previous"><a href="https://frontstretch.com/2017/02/06/ben-kennedy-joins-richard-childress-racing-for-nine-xfinity-series-races-in-2017/" rel="prev"><span>Previous</span> Ben Kennedy Joins Richard Childress Racing for 9 XFINITY Series Races in 2017</a></div>
			<div class="post-next"></div>
		</div><!-- .post-navigation -->
		
			<section id="related_posts">
		<div class="block-head">
			<h3>Related Articles</h3><div class="stripe-line"></div>
		</div>
		<div class="post-listing">
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://frontstretch.com/2017/02/06/ben-kennedy-joins-richard-childress-racing-for-nine-xfinity-series-races-in-2017/">
						<img width="310" height="165" src="https://frontstretch.com/wp-content/uploads/2016/12/ben-kennedy-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://frontstretch.com/2017/02/06/ben-kennedy-joins-richard-childress-racing-for-nine-xfinity-series-races-in-2017/" rel="bookmark">Ben Kennedy Joins Richard Childress Racing for 9 XFINITY Series Races in 2017</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>February 6, 2017</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://frontstretch.com/2017/02/02/tristar-motorsports-returning-to-the-cup-series-with-cole-whitt/">
						<img width="310" height="165" src="https://frontstretch.com/wp-content/uploads/2016/11/whittt-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://frontstretch.com/2017/02/02/tristar-motorsports-returning-to-the-cup-series-with-cole-whitt/" rel="bookmark">TriStar Motorsports Returning to Cup Series with Cole Whitt</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>February 2, 2017</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://frontstretch.com/2017/01/25/matt-dibenedetto-confident-in-move-to-go-fas-racing/">
						<img width="310" height="165" src="https://frontstretch.com/wp-content/uploads/2017/01/dibene-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://frontstretch.com/2017/01/25/matt-dibenedetto-confident-in-move-to-go-fas-racing/" rel="bookmark">Matt DiBenedetto Confident in Move to Go FAS Racing</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>January 25, 2017</span></p>
			</div>
						<div class="clear"></div>
		</div>
	</section>
	
			
	<section id="check-also-box" class="post-listing check-also-right">
		<a href="#" id="check-also-close"><i class="fa fa-close"></i></a>

		<div class="block-head">
			<h3>Check Also</h3>
		</div>

				<div class="check-also-post">
						
			<div class="post-thumbnail">
				<a href="https://frontstretch.com/2017/01/24/beyond-the-cockpit-landon-cassill-would-rather-be-overrated-than-underrated/">
					<img width="310" height="165" src="https://frontstretch.com/wp-content/uploads/2016/07/2016-Pocono-I-CUP-Landon-Cassill-Looking-Down-Anthony-Lumbis-Sr.-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" />					<span class="fa overlay-icon"></span>
				</a>
			</div><!-- post-thumbnail /-->
						
			<h2 class="post-title"><a href="https://frontstretch.com/2017/01/24/beyond-the-cockpit-landon-cassill-would-rather-be-overrated-than-underrated/" rel="bookmark">Beyond the Cockpit: Landon Cassill Would Rather Be Overrated Than Underrated</a></h2>
			<p>Prior to the end of the 2016 NASCAR season, Frontstretch ran an article discussing who we thought was the &hellip;</p>
		</div>
			</section>
			
			
	
		
				
<div id="comments">

	
	<div id="comments-box">
		<div class="block-head">
			<h3 id="comments-title">3 comments </h3><div class="stripe-line"></div>
		</div>
		<div class="post-listing">

			
					
				
			<ol class="commentlist">	<li id="comment-24764">
		<div  class="comment even thread-even depth-1 comment-wrap" >
			<div class="comment-avatar"><img src="https://secure.gravatar.com/avatar/d54be2016894209f461b337a27cd8b35?s=65&#038;d=mm&#038;r=g" width="65" height="65" alt="" class="avatar avatar-65wp-user-avatar wp-user-avatar-65 alignnone photo avatar-default" /></div>

			<div class="comment-content">
				<div class="author-comment">
					<cite class="fn">Upstate24fan</cite> 					<div class="comment-meta commentmetadata"><a href="https://frontstretch.com/2017/02/07/5-cup-series-drivers-who-need-to-win-in-2017/#comment-24764">	February 8, 2017 at 12:41 pm</a></div><!-- .comment-meta .commentmetadata -->
					<div class="clear"></div>
				</div>

				
				<p>I have a strong feeling Danica needs a win and/or to make the playoffs to stick in that ride.  Like many others, when the sponsorship dries up (e.g. Brian Scott) the ride goes bye-bye.  She has had plenty of opportunity to preform in quality equipment.  I was rooting for her, but I guess it&#8217;s not meant to be.</p>
			</div>
			<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://frontstretch.com/2017/02/07/5-cup-series-drivers-who-need-to-win-in-2017/?replytocom=24764#respond' onclick='return addComment.moveForm( "comment-24764", "24764", "respond", "129058" )' aria-label='Reply to Upstate24fan'>Reply</a></div><!-- .reply -->
		</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li id="comment-24761">
		<div  class="comment odd alt thread-odd thread-alt depth-1 comment-wrap" >
			<div class="comment-avatar"><img src="https://secure.gravatar.com/avatar/f1f68a9aca0693ab25f6204ad9e1a4f2?s=65&#038;d=mm&#038;r=g" width="65" height="65" alt="" class="avatar avatar-65wp-user-avatar wp-user-avatar-65 alignnone photo avatar-default" /></div>

			<div class="comment-content">
				<div class="author-comment">
					<cite class="fn">Josh</cite> 					<div class="comment-meta commentmetadata"><a href="https://frontstretch.com/2017/02/07/5-cup-series-drivers-who-need-to-win-in-2017/#comment-24761">	February 8, 2017 at 12:15 am</a></div><!-- .comment-meta .commentmetadata -->
					<div class="clear"></div>
				</div>

				
				<p>I agree with every driver except Danica Patrick. She doesn&#8217;t need to win because she has long hair. Hopefully she sucks so much this year that a kid or Greg Biffle or anyone can get that ride. It&#8217;s a top notch ride that runs 25th every week. Total joke. Her teammates run top 10 top 5 and compete for wins. Put Cole Custer in that thing. She&#8217;s had enough chances.</p>
			</div>
			<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://frontstretch.com/2017/02/07/5-cup-series-drivers-who-need-to-win-in-2017/?replytocom=24761#respond' onclick='return addComment.moveForm( "comment-24761", "24761", "respond", "129058" )' aria-label='Reply to Josh'>Reply</a></div><!-- .reply -->
		</div><!-- #comment-##  -->

	<ul class="children">
	<li id="comment-24762">
		<div  class="comment even depth-2 comment-wrap" >
			<div class="comment-avatar"><img src="https://secure.gravatar.com/avatar/9d0a766777366cd3f7f833437abcf640?s=65&#038;d=mm&#038;r=g" width="65" height="65" alt="" class="avatar avatar-65wp-user-avatar wp-user-avatar-65 alignnone photo avatar-default" /></div>

			<div class="comment-content">
				<div class="author-comment">
					<cite class="fn">Russ</cite> 					<div class="comment-meta commentmetadata"><a href="https://frontstretch.com/2017/02/07/5-cup-series-drivers-who-need-to-win-in-2017/#comment-24762">	February 8, 2017 at 7:02 am</a></div><!-- .comment-meta .commentmetadata -->
					<div class="clear"></div>
				</div>

				
				<p>I&#8217;m sure they would be happy to replace her with somebody. And its obvious that she is preparing for that day.  Of course there is the little matter of their having to bring millions of dollars of sponsorship with them. If they can no problem. Until then its not even a talking point</p>
			</div>
			<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://frontstretch.com/2017/02/07/5-cup-series-drivers-who-need-to-win-in-2017/?replytocom=24762#respond' onclick='return addComment.moveForm( "comment-24762", "24762", "respond", "129058" )' aria-label='Reply to Russ'>Reply</a></div><!-- .reply -->
		</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ol>
				
		 

			
					
			
		</div>
	</div><!-- #comments-box -->
			

<div class="clear"></div>
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/02/07/5-cup-series-drivers-who-need-to-win-in-2017/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://frontstretch.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='129058' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="529c162a02" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="192"/></p>			</form>
			</div><!-- #respond -->
	

</div><!-- #comments -->

	</div><!-- .content -->
<aside id="sidebar">
	<div class="theiaStickySidebar">
		<div id="ads300_250-widget-8" class="e3lan-widget-content e3lan300-250">
								<div class="e3lan-cell">
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Main Page Ad -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-1931074544731095"
     data-ad-slot="2498160170"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
			</div>
				</div>
	<div id="text-42" class="widget widget_text"><div class="widget-top"><h4>Connect with Frontstretch</h4><div class="stripe-line"></div></div>
						<div class="widget-container">			<div class="textwidget"><center>
<a href="https://twitter.com/frontstretch" onclick="__gaTracker('send', 'event', 'outbound-widget', 'https://twitter.com/frontstretch', '');"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Twitter-Logo.png" style="width:60px;height:60px;border:0;"></a>

<a href="https://www.facebook.com/Frontstretch" onclick="__gaTracker('send', 'event', 'outbound-widget', 'https://www.facebook.com/Frontstretch', '');"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Facebook_Logo.png" style="width:60px;height:60px;border:0;"></a>

<a href="https://instagram.com/frontstretchdotcom/" onclick="__gaTracker('send', 'event', 'outbound-widget', 'https://instagram.com/frontstretchdotcom/', '');"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Instagram-Logo.jpg" style="width:60px;height:60px;border:0;"></a>

<a href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" onclick="__gaTracker('send', 'event', 'outbound-widget', 'https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw', '');"><img src="https://frontstretch.com/wp-content/uploads/2015/07/YouTube-Logo.png" style="width:60px;height:60px;border:0;"></a>

<br /><br />

<a href="https://frontstretch.com/podcast/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Podcast-Logo.png" style="width:60px;height:60px;border:0;"></a>

<a href="https://frontstretch.com/feed/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/RSS-Logo.jpg" style="width:60px;height:60px;border:0;"></a>

<a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" onclick="__gaTracker('send', 'event', 'outbound-widget', 'https://itunes.apple.com/us/podcast/frontstretch/id1023154421', '');"><img src="https://frontstretch.com/wp-content/uploads/2015/07/iTunes-Logo.png" style="width:60px;height:60px;border:0;"></a>

</center></div>
		</div></div><!-- .widget /-->		<div id="ads250_250-widget-7" class="e3lan-widget-content e3lan250-250">
								<div class="e3lan-cell">
				<a href="http://www.americanmuscle.com"  target="_blank"  >					<img src="https://frontstretch.com/wp-content/uploads/2014/06/American-Muscle-250x250.jpg" alt="" />
				</a>			</div>
				</div>
	<div id="enhancedtextwidget-2" class="widget widget_text enhanced-text-widget"><div class="widget-top"><h4>Promo Code NASCAR5 Earns 5% Off ($150 Minimum) on TicketLiquidator!</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><div class="textwidget widget-text"><!-- TL Search Widget start --><script type="text/javascript" src="https://tickettransaction2.com/Brokers/01504-011/WidgetJS/scriptsretail-stringutils.js"></script><script type="text/javascript">var widgetCSS = document.createElement("link");widgetCSS.setAttribute("rel", "stylesheet");widgetCSS.setAttribute("type", "text/css");widgetCSS.setAttribute("href", "https://tickettransaction2.com/Brokers/01504-011/WidgetCSS/Style.css");document.getElementsByTagName("head")[0].appendChild(widgetCSS);</script><div id="TL_Search_Widget" style="width: 200px; border: 1px solid rgb(218, 212, 200);"><div id="tlsw_header"><img src="//s3.amazonaws.com/ticketliquidator/affiliates/widgetMaker/SearchWidget/findtickets.png"><input id="tlsw_searchTxt" value="Search by Track or Event" onblur="if(this.value=='') this.value=this.defaultValue;" onfocus="if(this.value==this.defaultValue) this.value='';" type="text"><div id="tlsw_searchBtn" style="background-image: url(&quot;//s3.amazonaws.com/ticketliquidator/affiliates/widgetMaker/SearchWidget/blue_btn.png&quot;);" onclick="tn_SubmitSearch()"><script type="text/javascript">function tn_KeyDownHandler(e) {if (e == null) e = window.event;if (e.keyCode == 13) tn_SubmitSearch();}document.getElementById('tlsw_searchTxt').onkeypress = tn_KeyDownHandler;</script></div></div><ul id="tlsw_content" class="suggestionsArea"><li class="tlsw_suggestion" onmouseover="this.style.backgroundPosition='bottom right';" onmouseout="this.style.backgroundPosition='top right';" style="background-image:url(https://s3.amazonaws.com/ticketliquidator/affiliates/widgetMaker/SearchWidget/red-bg.png);"><a target="_blank" href="//www.jdoqocy.com/click-7929989-10858765?sid=&amp;url=http://www.ticketliquidator.com/tix/nascar-sprint-cup-series-tickets.aspx"><span class="tlsw_linktext">Sprint Cup</span></a></li><li class="tlsw_suggestion" onmouseover="this.style.backgroundPosition='bottom right';" onmouseout="this.style.backgroundPosition='top right';" style="background-image:url(https://s3.amazonaws.com/ticketliquidator/affiliates/widgetMaker/SearchWidget/red-bg.png);"><a target="_blank" href="//www.jdoqocy.com/click-7929989-10858765?sid=&amp;url=http://www.ticketliquidator.com/tix/nascar-xfinity-series-tickets.aspx"><span class="tlsw_linktext">Xfinity Series</span></a></li><li class="tlsw_suggestion" onmouseover="this.style.backgroundPosition='bottom right';" onmouseout="this.style.backgroundPosition='top right';" style="background-image:url(https://s3.amazonaws.com/ticketliquidator/affiliates/widgetMaker/SearchWidget/red-bg.png);"><a target="_blank" href="//www.jdoqocy.com/click-7929989-10858765?sid=&amp;url=http://www.ticketliquidator.com/tix/nascar-camping-world-truck-series-tickets.aspx"><span class="tlsw_linktext">Camping World Truck Series</span></a></li></ul><div id="tlsw_scripts"><script type="text/javascript">function tn_SubmitSearch() {var SearchPhrase = document.getElementById('tlsw_searchTxt').value.trim().replace(/\s/g, '-');window.open('//www.jdoqocy.com/click-7929989-10858765?sid=&amp;url=' + 'http://www.ticketliquidator.com/tix/' + SearchPhrase + '-tickets.aspx');}</script></div><div id="tlsw_footer"><a id="tlsw_footer_link" href="//www.jdoqocy.com/click-7929989-10858765?sid=&amp;url=http://www.ticketliquidator.com/default.aspx" target="_blank"><img src="//s3.amazonaws.com/ticketliquidator/affiliates/widgetMaker/SearchWidget/logo.png"></a></div></div><!-- TL Search Widget end --></div></div></div><!-- .widget /--><div id="text-34" class="widget widget_text"><div class="widget-top"><h4> </h4><div class="stripe-line"></div></div>
						<div class="widget-container">			<div class="textwidget"><center><a href="http://starcoachracetours.com/" onclick="__gaTracker('send', 'event', 'outbound-widget', 'http://starcoachracetours.com/', '');"><img src="https://frontstretch.com/wp-content/uploads/2015/02/starcoach_logo_fullcolor-2-1-e1424317191919.jpg"></a>
<br>
<A HREF=" https://frontstretch.com/star-coach-race-tours-provides-the-epitome-of-nascar-luxury/">Star Coach Race Tours Provides the Epitome of NASCAR Luxury</A></center></div>
		</div></div><!-- .widget /-->		<div id="ads300_250-widget-2" class="e3lan-widget-content e3lan300-250">
								<div class="e3lan-cell">
				<a href="http://www.fanvision.com/"  target="_blank"  >					<img src="https://frontstretch.com/wp-content/uploads/2014/05/12248.jpg" alt="" />
				</a>			</div>
				</div>
	<div id="text-5" class="widget widget_text"><div class="widget-top"><h4> </h4><div class="stripe-line"></div></div>
						<div class="widget-container">			<div class="textwidget"><a href="http://thepitlane.org/" onclick="__gaTracker('send', 'event', 'outbound-widget', 'http://thepitlane.org/', '');"><img src="https://frontstretch.com/wp-content/uploads/2013/02/The-Pit-Lane-Formatted.jpg"></a></div>
		</div></div><!-- .widget /-->	</div><!-- .theiaStickySidebar /-->
</aside><!-- #sidebar /-->	<div class="clear"></div>
</div><!-- .container /-->

				
<div class="clear"></div>
<div class="footer-bottom">
	<div class="container">
		<div class="alignright">
			© Copyright 2017, All Rights Reserved		</div>
				<div class="social-icons">
		<a class="ttip-none" title="Rss" href="https://frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a>
			</div>

		
		<div class="alignleft">
			All images are the property of their respective photographers. These images may not be reproduced, copied or transmitted without the written consent of the photographer.		</div>
		<div class="clear"></div>
	</div><!-- .Container -->
</div><!-- .Footer bottom -->

</div><!-- .inner-Wrapper -->
</div><!-- #Wrapper -->
</div><!-- .Wrapper-outer -->
	<div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div>
<div id="fb-root"></div>
<script language="javascript" type="text/javascript">var kpg_cell="N";var kpg_nrci_image="https://frontstretch.com/wp-content/plugins/no-right-click-images-plugin/not.gif";var kpg_nrci_extra="N";var kpg_nrci_drag="Y";</script>
<script language="javascript" type="text/javascript" src="https://frontstretch.com/wp-content/plugins/no-right-click-images-plugin/no-right-click-images.js"></script>

		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script type='text/javascript'> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};/* ]]> */ </script><script type='text/javascript' src='https://frontstretch.com/wp-content/plugins/akismet/_inc/form.js'></script>
<script type='text/javascript' src='https://frontstretch.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://frontstretch.com/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","SmothScroll":"true","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script type='text/javascript' src='https://frontstretch.com/wp-content/themes/sahifa/js/tie-scripts.js'></script>
<script type='text/javascript' src='https://frontstretch.com/wp-content/themes/sahifa/js/ilightbox.packed.js'></script>
<script type='text/javascript' src='https://frontstretch.com/wp-includes/js/comment-reply.js'></script>
<script type='text/javascript' src='https://frontstretch.com/wp-includes/js/wp-embed.js'></script>
<script type='text/javascript' src='https://frontstretch.com/wp-content/themes/sahifa/js/search.js'></script>
<script type="text/css" id="tmpl-tribe_customizer_css">.tribe-events-list .tribe-events-loop .tribe-event-featured,
				.tribe-events-list #tribe-events-day.tribe-events-loop .tribe-event-featured,
				.type-tribe_events.tribe-events-photo-event.tribe-event-featured .tribe-events-photo-event-wrap,
				.type-tribe_events.tribe-events-photo-event.tribe-event-featured .tribe-events-photo-event-wrap:hover {
					background-color: #0ea0d7;
				}

				#tribe-events-content table.tribe-events-calendar .type-tribe_events.tribe-event-featured {
					background-color: #0ea0d7;
				}

				.tribe-events-list-widget .tribe-event-featured,
				.tribe-events-venue-widget .tribe-event-featured,
				.tribe-mini-calendar-list-wrapper .tribe-event-featured,
				.tribe-events-adv-list-widget .tribe-event-featured .tribe-mini-calendar-event {
					background-color: #0ea0d7;
				}

				.tribe-grid-body .tribe-event-featured.tribe-events-week-hourly-single {
					background-color: rgba(14,160,215, .7 );
					border-color: #0ea0d7;
				}

				.tribe-grid-body .tribe-event-featured.tribe-events-week-hourly-single:hover {
					background-color: #0ea0d7;
				}</script><style type="text/css" id="tribe_customizer_css">.tribe-events-list .tribe-events-loop .tribe-event-featured,
				.tribe-events-list #tribe-events-day.tribe-events-loop .tribe-event-featured,
				.type-tribe_events.tribe-events-photo-event.tribe-event-featured .tribe-events-photo-event-wrap,
				.type-tribe_events.tribe-events-photo-event.tribe-event-featured .tribe-events-photo-event-wrap:hover {
					background-color: #0ea0d7;
				}

				#tribe-events-content table.tribe-events-calendar .type-tribe_events.tribe-event-featured {
					background-color: #0ea0d7;
				}

				.tribe-events-list-widget .tribe-event-featured,
				.tribe-events-venue-widget .tribe-event-featured,
				.tribe-mini-calendar-list-wrapper .tribe-event-featured,
				.tribe-events-adv-list-widget .tribe-event-featured .tribe-mini-calendar-event {
					background-color: #0ea0d7;
				}

				.tribe-grid-body .tribe-event-featured.tribe-events-week-hourly-single {
					background-color: rgba(14,160,215, .7 );
					border-color: #0ea0d7;
				}

				.tribe-grid-body .tribe-event-featured.tribe-events-week-hourly-single:hover {
					background-color: #0ea0d7;
				}</style></body>
</html>